Payment Issues
Incident Report for SCORM Cloud
Resolved
We have resolved the issues with the payment processor. If your account is still affected, please contact us at support@scorm.com.
Posted 9 months ago. Jan 10, 2017 - 15:50 UTC
Investigating
We are investigating an issue with our credit card processor that is preventing administrators from changing their billing plan. This issue may also be preventing some accounts from creating new registrations.
Posted 9 months ago. Jan 10, 2017 - 15:03 UTC