SCORM Cloud Degraded Performance

Incident Report for SCORM Cloud

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 23:11 UTC

Update

Service has been restored. Thank you for your patience.
Posted Oct 20, 2025 - 23:04 UTC

Update

We are continuing to experience performance degradation due to the ongoing increased error rates and latencies with AWS. Our engineering team remains actively engaged in monitoring AWS status updates and applying necessary mitigations to reduce impact. We understand the critical nature of SCORM Cloud’s availability and are prioritizing restoration of full functionality. Thank you for your continued patience as we work through these challenges.
Posted Oct 20, 2025 - 20:59 UTC

Identified

Due to a large AWS outage early this morning at roughly 7:11AM UTC, SCORM Cloud has been experiencing degraded performance due to it's reliance on AWS.
We are monitoring and mitigating issues as we can during these times and thank you for your patience.
Posted Oct 20, 2025 - 15:03 UTC
This incident affected: SCORM Cloud Website and SCORM Cloud API.